Pitney Bowes First Class Mail Rate Issues
Incident Report for ShipHawk
Resolved
Pitney Bowes released a fix for multiple rates returning for first class mail.
Posted Feb 16, 2020 - 13:41 PST
Update
We are preparing a fix for this issue.
Posted Feb 14, 2020 - 13:41 PST
Investigating
Pitney Bowes is returning erroneous sets of rates for first class mail. We are working with Pitney Bowes and investigating a solution.
Posted Feb 14, 2020 - 11:37 PST
This incident affected: Rates.