Pitney Bowes Expedited Delivery Services partial unavailability
Incident Report for ShipHawk
Resolved
This incident has been resolved.
Posted Nov 28, 2023 - 10:21 PST
Update
We are continuing to investigate this issue.
Posted Nov 28, 2023 - 10:12 PST
Investigating
Pitney Bowes has notified us they are experiencing an API Degraded Performance. Customers who use Pitney Bowes may experience slowness or unavailability of Pitney Bowes shipping rates or printing labels. We will continue to monitor their progress as they resolve this issue.

For additional information use Pitney Bowes status page - https://apistatus.pitneybowes.com/incidents/z9dm61vtz8kq
Posted Nov 28, 2023 - 09:06 PST
This incident affected: Carrier/3PL Connectors (USPS via Pitney Bowes).