Endicia Partial Outage
Incident Report for ShipHawk
Resolved
Endicia is now operational. For status updates on Endicia, see https://status.endicia.com/
Posted 18 days ago. Sep 27, 2019 - 16:58 PDT
Investigating
Endicia is experiencing customers being unable to print or purchase postage. ShipHawk is monitoring the situation. See https://status.endicia.com for details.
Posted 18 days ago. Sep 27, 2019 - 10:35 PDT
This incident affected: USPS Endicia API.