Pitney Bowes Expedited Delivery Services slowness
Incident Report for ShipHawk
Resolved
This incident has been resolved by Pitney Bowes.
Posted Oct 16, 2023 - 15:19 PDT
Identified
Pitney Bowes has notified us they are experiencing an API Degraded Performance. Customers who use Pitney Bowes may experience slowness in getting shipping rates or printing labels. We will continue to monitor their progress as they resolve this issue.

For additional information use Pitney Bowes status page - https://apistatus.pitneybowes.com/
Posted Oct 16, 2023 - 12:06 PDT
This incident affected: Carrier/3PL Connectors (USPS via Pitney Bowes).