Slow database performance
Incident Report for ShipHawk
Resolved
This incident has been resolved.
Posted about 1 year ago. Sep 15, 2018 - 10:52 PDT
Investigating
We're seeing slow database performance which is causing slow response times. We are investigating the issue.
Posted about 1 year ago. Sep 15, 2018 - 09:43 PDT
This incident affected: ShipHawk Dashboard, ShipHawk API, Rates, Item Search, and Label Printing.