USPS Endicia API is experiencing technical problems
Incident Report for ShipHawk
Resolved
This incident has been resolved.
Posted 5 months ago. May 06, 2019 - 11:46 PDT
Monitoring
The Endicia Label Server API is currently experiencing extreme slowness and subsequent timeouts when requesting rates and labels. They are actively working to resolve the issue.
Posted 5 months ago. May 06, 2019 - 09:08 PDT
This incident affected: USPS Endicia API.