The UPS API is responding slowly and timing out. We are monitoring the situation.
Incident Report for ShipHawk
Resolved
This incident has been resolved.
Posted Nov 09, 2018 - 15:33 PST
Monitoring
Rates, labels, and tracking are affected.
Posted Nov 09, 2018 - 10:22 PST
This incident affected: Carrier/3PL Connectors (UPS Web Services).