USPS Rating and Label Printing Offline
Incident Report for ShipHawk
Resolved
We've updated the USPS passwords and USPS is back on-line.
Posted Aug 13, 2015 - 11:32 PDT
Investigating
We're currently not able to rate or print labels for USPS. This will be resolved asap.
Posted Aug 13, 2015 - 10:31 PDT