Plycon rates are not returning.
Incident Report for ShipHawk
Resolved
The Plycon rating issue has been resolved.
Posted Mar 08, 2016 - 16:37 PST
Investigating
We are investigating the issue.
Posted Mar 08, 2016 - 15:19 PST