Slow response times
Incident Report for ShipHawk
Resolved
The issue has been resolved.
Posted 12 months ago. Oct 23, 2018 - 17:11 PDT
Investigating
We're investigating an issue with slow response times; we're investigating it now.
Posted 12 months ago. Oct 23, 2018 - 16:58 PDT
This incident affected: ShipHawk Dashboard, ShipHawk API, Rates, Item Search, and Label Printing.