Increased system latency
Incident Report for ShipHawk
Resolved
We've identified and resolved the database performance issue. All systems are operating normally.
Posted 12 months ago. Oct 19, 2018 - 12:26 PDT
Investigating
We're currently investigating an issue that is causing slow performance.
Posted 12 months ago. Oct 19, 2018 - 09:34 PDT
This incident affected: ShipHawk Dashboard, ShipHawk API, Rates, Item Search, and Label Printing.